NCTAudioGrabber2Lib

NCTAudioStudio2 ActiveX DLLs
NCTAudioGrabber2 ActiveX DLL

Version 2.2

NCTAudioGrabber2 ActiveX DLL is intended for grabbing audio from an audio CD.

With NCTAudioGrabber2 ActiveX DLL you can:

  • Determinate the type of a CD drive;

  • Determinate the number of tracks on an audio CD;

  • Grab audio tracks from an audio CD;

  • Get the CDDB info.

NCTAudioGrabber2 is a part of the NCTAudioStudio2 package.

Send Feedback on the NCTAudioGrabber2 documentation.
NCTAudioGrabber2 was developed by NCT Company Ltd. http://www.nctsoft.com


AudioGrabber2 properties

AudioGrabber2 properties

Property | Type | Default | Description
cddbAgentName | String | "NCTAudioGrabber2 1.06" | Gets or sets the string with the application name and its version, which sends a request to the CDDB info base.
cddbCGIScript | String | "/~cddb/cddb.cgi" | Gets or sets the string with the the CDDB .cgi script address on the CDDB site.
cddbInfoAlbum | String |  | Read-only property that returns the string with the audio CD album name.
cddbInfoArtist | String |  | Read-only property that returns the string with the name of the artist who created the original subject of the audio CD. If there are many artists, the names are separated by a semicolon and a blank.
cddbInfoGenre | String |  | Read-only property that returns the genre or classification of an audio CD.
cddbInfoTitle | String |  | Read-only property that returns the string with the title of an audio track.
cddbServerAddress | String | "http://freedb.freedb.org" | Gets or sets the string with the CDDB server URL.
cddbServerHTTPPort | Long | 80 | Gets or sets the HTTP port number.
cddbTimeOut | Long |  | Read-only property that returns TimeOut on query of CDDB Server.
cddbUserEMail | String |  | Gets or sets the string with the user e-mail address.
cdID | Long |  | Read-only property that returns the ID of an audio CD.
cdType | CDDiskType |  | Read-only property that returns the type of the drive.
driveCount | Long |  | Read-only property that returns the maximal number of CD drives in the system.
driveLetter | String |  | Read-only property that returns the letter associated with the current drive in the system.
driveLockCDTrayDuringGrab | Boolean |  | Gets or sets a flag indicating if the locking drive tray is enabled or disabled during grabbing.
driveName | String |  | Read-only property that returns the name of the current CD drive in the system. The current CD drive must be set by the driveNum property preliminary.
driveNum | Long |  | Gets or sets the number of the current CD drive in the system.
driveReadType | ReadTypeConstants |  | Read-only property that returns the type of the CD.
driveSpeed | Long |  | Read-only property that returns the maximal drive speed during grabbing.
driveSpinUpTime | Long |  | Gets or sets drive Spin Up time before grabbing.
GrabModePreset | GrabModePreset |  | Gets or sets grab mode preset.
grabOnErrorAction | GrabActionOnError |  | Gets or sets an action on reading or synching an error during grabbing.
grabOnErrorRetries | Long |  | Gets or sets re-read retries number on reading or synching an error during grabbing.
grabSafeMode | Boolean |  | Gets or sets a flag indicating if safe grabbing mode is enabled or not.
grabUseExternalASPI | Boolean |  | Gets or sets NCTAudioGrabber2 to use a third-party ASPI-driver.
LastErrorNum | ErrorConstants |  | Read-only property that returns the number of the last error.
sfmdCoolDownTime | Long |  | Read-only property that returns safe mode cool down time.
sfmdGrabTime | Long |  | Read-only property that returns safe mode grabbing time.
Status | Long |  | Read-only property that returns the current status of the control if extracting audio operations in progress.
trackCount | Long |  | Read-only property that returns the number of tracks on the compact disk.
trackDuration | Long |  | Read-only property that returns the duration of the track, which is set using the cdNum property.
trackNum | Long |  | Gets or sets the current track.
trackSamples | Long |  | Read-only property that returns the number of samples in the track, which is set using the trackNum property.


cddbAgentName property (AudioGrabber2)

cddbAgentName property (AudioGrabber2)

Gets or sets the string with the application name and its version, which sends a request to the CDDB info base.

Property type

A String value.

Syntax

object.cddbAgentName [= value]

The cddbAgentName property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | String | By default this value is set to "NCTAudioGrabber 1.06".

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Grabber.cddbUserEMail = "support@nctsoft.com"
'These are the parameters for getting cddb from "http://freedb.freedb.org"
Grabber.GetCDDBInfo  , TRUE  'gets cddb from "http://freedb.freedb.org"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Timeout.Caption = Grabber.cddbTimeOut & "ms"

See Also:

cddbCGIScript | cddbInfoAlbum | cddbInfoArtist | cddbInfoGenre | cddbInfoTitle | cddbServerAddress | cddbServerHTTPPort | cddbTimeOut | cddbUserEMail

Apples To: AudioGrabber2


cddbCGIScript property (AudioGrabber2)

cddbCGIScript property (AudioGrabber2)

Gets or sets the string with the the CDDB .cgi script address on the CDDB site.

Property type

A String value.

Syntax

object.cddbCGIScript [= value]

The cddbCGIScript property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | String | By default this value is set to "/~cddb/cddb.cgi" for http://freedb.freedb.org CDDB server.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Grabber.cddbUserEMail = "support@nctsoft.com"
'These are the parameters for getting cddb from "http://freedb.freedb.org"
Grabber.GetCDDBInfo  , TRUE  'gets cddb from "http://freedb.freedb.org"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Timeout.Caption = Grabber.cddbTimeOut & "ms"

See Also:

cddbAgentName | cddbInfoAlbum | cddbInfoArtist | cddbInfoGenre | cddbInfoTitle | cddbServerAddress | cddbServerHTTPPort | cddbTimeOut | cddbUserEMail

Apples To: AudioGrabber2


cddbInfoAlbum property (AudioGrabber2)

cddbInfoAlbum property (AudioGrabber2)

Read-only property that returns the string with the audio CD album name.

Property type

A String value.

Syntax

[value = ]object.cddbInfoAlbum

The cddbInfoAlbum property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | String | Album name.

Remarks:

cddbinfoAlbum property accepts correct value only after applying of the GetCDDBInfo method.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Grabber.cddbUserEMail = "support@nctsoft.com"
'These are the parameters for getting cddb from "http://freedb.freedb.org"
Grabber.GetCDDBInfo  , TRUE  'gets cddb from "http://freedb.freedb.org"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Timeout.Caption = Grabber.cddbTimeOut & "ms"

See Also:

cddbAgentName | cddbCGIScript | cddbInfoArtist | cddbInfoGenre | cddbInfoTitle | cddbServerAddress | cddbServerHTTPPort | cddbTimeOut | cddbUserEMail

Apples To: AudioGrabber2


cddbInfoArtist property (AudioGrabber2)

cddbInfoArtist property (AudioGrabber2)

Read-only property that returns the string with the name of the artist who created the original subject of the audio CD. If there are many artists, the names are separated by a semicolon and a blank.

Property type

A String value.

Syntax

[value = ]object.cddbInfoArtist

The cddbInfoArtist property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | String | Artist's name.

Remarks:

cddbinfoArtist property accepts correct value only after applying of the GetCDDBInfo method

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Grabber.cddbUserEMail = "support@nctsoft.com"
'These are the parameters for getting cddb from "http://freedb.freedb.org"
Grabber.GetCDDBInfo  , TRUE  'gets cddb from "http://freedb.freedb.org"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Timeout.Caption = Grabber.cddbTimeOut & "ms"

See Also:

cddbAgentName | cddbCGIScript | cddbInfoAlbum | cddbInfoGenre | cddbInfoTitle | cddbServerAddress | cddbServerHTTPPort | cddbTimeOut | cddbUserEMail

Apples To: AudioGrabber2


cddbInfoGenre property (AudioGrabber2)

cddbInfoGenre property (AudioGrabber2)

Read-only property that returns the genre or classification of an audio CD.

Property type

A String value.

Syntax

[value = ]object.cddbInfoGenre

The cddbInfoGenre property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | String | Audio CD Genre.

Remarks:

infoGenre property accepts correct meaning only after applying of the GetCDDBInfo method.

The list of genres is in the Genre string.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Grabber.cddbUserEMail = "support@nctsoft.com"
'These are the parameters for getting cddb from "http://freedb.freedb.org"
Grabber.GetCDDBInfo  , TRUE  'gets cddb from "http://freedb.freedb.org"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Timeout.Caption = Grabber.cddbTimeOut & "ms"

See Also:

cddbAgentName | cddbCGIScript | cddbInfoAlbum | cddbInfoArtist | cddbInfoTitle | cddbServerAddress | cddbServerHTTPPort | cddbTimeOut | cddbUserEMail

Apples To: AudioGrabber2


cddbInfoTitle property (AudioGrabber2)

cddbInfoTitle property (AudioGrabber2)

Read-only property that returns the string with the title of an audio track.

Property type

A String value.

Syntax

[value = ]object.cddbInfoTitle

The cddbInfoTitle property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | String | Audio track title.

Remarks:

cddbinfoTitle property accepts correct value only after applying of the GetCDDBInfo method.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Grabber.cddbUserEMail = "support@nctsoft.com"
'These are the parameters for getting cddb from "http://freedb.freedb.org"
Grabber.GetCDDBInfo  , TRUE  'gets cddb from "http://freedb.freedb.org"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Timeout.Caption = Grabber.cddbTimeOut & "ms"

See Also:

cddbAgentName | cddbCGIScript | cddbInfoAlbum | cddbInfoArtist | cddbInfoGenre | cddbServerAddress | cddbServerHTTPPort | cddbTimeOut | cddbUserEMail

Apples To: AudioGrabber2


cddbServerAddress property (AudioGrabber2)

cddbServerAddress property (AudioGrabber2)

Gets or sets the string with the CDDB server URL.

Property type

A String value.

Syntax

object.cddbServerAddress [= value]

The cddbServerAddress property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | String | By default this value is set to "http://freedb.freedb.org".

Remarks:

If you change the CDDB URL don't forget to change also cddbCGIScript property.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Grabber.cddbUserEMail = "support@nctsoft.com"
'These are the parameters for getting cddb from "http://freedb.freedb.org"
Grabber.GetCDDBInfo  , TRUE  'gets cddb from "http://freedb.freedb.org"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Timeout.Caption = Grabber.cddbTimeOut & "ms"

See Also:

cddbAgentName | cddbCGIScript | cddbInfoAlbum | cddbInfoArtist | cddbInfoGenre | cddbInfoTitle | cddbServerHTTPPort | cddbTimeOut | cddbUserEMail

Apples To: AudioGrabber2


cddbServerHTTPPort property (AudioGrabber2)

cddbServerHTTPPort property (AudioGrabber2)

Gets or sets the HTTP port number.

Property type

A Long value.

Syntax

object.cddbServerHTTPPort [= value]

The cddbServerHTTPPort property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | HTTP port number. By default this value is set to 80.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Grabber.cddbUserEMail = "support@nctsoft.com"
'These are the parameters for getting cddb from "http://freedb.freedb.org"
Grabber.GetCDDBInfo  , TRUE  'gets cddb from "http://freedb.freedb.org"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Timeout.Caption = Grabber.cddbTimeOut & "ms"

See Also:

cddbAgentName | cddbCGIScript | cddbInfoAlbum | cddbInfoArtist | cddbInfoGenre | cddbInfoTitle | cddbServerAddress | cddbTimeOut | cddbUserEMail

Apples To: AudioGrabber2


cddbTimeOut property (AudioGrabber2)

cddbTimeOut property (AudioGrabber2 object)

Read-only property that returns TimeOut on query of CDDB Server.

Property type

A Long value.

Syntax

[value = ]object.cddbTimeOut

The cddbTimeOut property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | Timeout in milliseconds.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Grabber.cddbUserEMail = "support@nctsoft.com"
'These are the parameters for getting cddb from "http://freedb.freedb.org"
Grabber.GetCDDBInfo  , TRUE  'gets cddb from "http://freedb.freedb.org"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Timeout.Caption = Grabber.cddbTimeOut & "ms"

See Also:

cddbAgentName | cddbCGIScript | cddbInfoAlbum | cddbInfoArtist | cddbInfoGenre | cddbInfoTitle | cddbServerAddress | cddbServerHTTPPort | cddbUserEMail

Apples To: AudioGrabber2

Send Feedback on the NCTAudioGrabber2 documentation.
NCTAudioGrabber2 was developed by NCT company http://www.nctsoft.com


cddbUserEMail property (AudioGrabber2)

cddbUserEMail property (AudioGrabber2)

Gets or sets the string with the user e-mail address.

Property type

A String value.

Syntax

object.cddbUserEMail [= value]

The cddbUserEMail property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | String | The user e-mail address.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Grabber.cddbUserEMail = "support@nctsoft.com"
'These are the parameters for getting cddb from "http://freedb.freedb.org"
Grabber.GetCDDBInfo  , TRUE  'gets cddb from "http://freedb.freedb.org"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Timeout.Caption = Grabber.cddbTimeOut & "ms"
Grabber.cddbUserEMail = "support@nctsoft.com"

See Also:

cddbAgentName | cddbCGIScript | cddbInfoAlbum | cddbInfoArtist | cddbInfoGenre | cddbInfoTitle | cddbServerAddress | cddbServerHTTPPort | cddbTimeOut

Apples To: AudioGrabber2


cdID property (AudioGrabber2)

cdID property (AudioGrabber2)

Read-only property that returns the ID of an audio CD.

Property type

A Long value.

Syntax

[value = ]object.cdID

The cdID property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | ID of audio CD.

See Also:

cdType

Apples To: AudioGrabber2


cdType property (AudioGrabber2)

cdType property (AudioGrabber2)

Read-only property that returns the type of the drive.

Property type

A CDDiskType value.

Syntax

[value = ]object.cdType

The cdType property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | CDDiskType | The type of the drive.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Dim cdTypeString As String
AGrabber.RefreshCD
Select Case Grabber.cdType
Case UNRECOGNIZED:
cdTypeString = "No Disc"
Case REDBOOK:
cdTypeString = "CD Digital Audio Disk"
Case YELLOWBOOK:
cdTypeString = "Data CD. Single Session"
Case ORANGEBOOK:
cdTypeString = "Data CD (Multisession)"
Case GREENBOOK:
cdTypeString = "CD-Interactive"
Case BLUEBOOK:
cdTypeString = "CD-Extra"
End Select

See Also:

cdID

Apples To: AudioGrabber2


driveCount property (AudioGrabber2)

driveCount property (AudioGrabber2)

Read-only property that returns the maximal number of CD drives in the system.

Property type

A Long value.

Syntax

[value = ]object.driveCount

The driveCount property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | The maximal number of CD drives in the system.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Dim i As Integer
Dim DriveName As String
i = 0
Do While i < Grabber.driveCount
    i = i + 1
    Grabber.driveNum = i
    DriveName = ""
    If Grabber.driveLockCDTrayDuringGrab Then DriveName = "Locked"
    DriveName = DriveName & "Drive " & Grabber.driveNum & ": " & Grabber.driveName & " "
    DriveName = DriveName & Grabber.driveReadType & " with" & Grabber.driveSpead & "speed and Spin Up time:"
    DriveName = DriveName & Grabber.driveSpinUpTime & "ms"
    'For example this string with drive information can be visualized on the form like a label
Loop

See Also:

driveLetter | driveLockCDTrayDuringGrab | driveName | driveNum | driveReadType | driveSpeed | driveSpinUpTime

Apples To: AudioGrabber2


driveLetter property (AudioGrabber2)

driveLetter property (AudioGrabber2)

Read-only property that returns the letter associated with the current drive in the system.

Property type

A String value.

Syntax

[value = ]object.driveLetter

The driveLetter property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | String | The letter associated with the current drive.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Dim i As Integer
Dim DriveName As String
i = 0
Do While i < Grabber.driveCount
    i = i + 1
    Grabber.driveNum = i
    DriveName = ""
    If Grabber.driveLockCDTrayDuringGrab Then DriveName = "Locked"
    DriveName = DriveName & "Drive " & Grabber.driveNum & ": " & Grabber.driveName & " "
    DriveName = DriveName & Grabber.driveReadType & " with" & Grabber.driveSpead & "speed and Spin Up time:"
    DriveName = DriveName & Grabber.driveSpinUpTime & "ms"
    'For example this string with drive information can be visualized on the form like a label
Loop

See Also:

driveCount | driveLockCDTrayDuringGrab | driveName | driveNum | driveReadType | driveSpeed | driveSpinUpTime

Apples To: AudioGrabber2


driveLockCDTrayDuringGrab property (AudioGrabber2)

driveLockCDTrayDuringGrab property (AudioGrabber2)

Gets or sets a flag indicating if the locking drive tray is enabled or disabled during grabbing.

Syntax

object.driveLockCDTrayDuringGrab [= value]

The driveLockCDTrayDuringGrab property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Boolean | True if the locking drive tray is enabled during grab, otherwise - False.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Dim i As Integer
Dim DriveName As String
i = 0
Do While i < Grabber.driveCount
    i = i + 1
    Grabber.driveNum = i
    DriveName = ""
    If Grabber.driveLockCDTrayDuringGrab Then DriveName = "Locked"
    DriveName = DriveName & "Drive " & Grabber.driveNum & ": " & Grabber.driveName & " "
    DriveName = DriveName & Grabber.driveReadType & " with" & Grabber.driveSpead & "speed and Spin Up time:"
    DriveName = DriveName & Grabber.driveSpinUpTime & "ms"
    'For example this string with drive information can be visualized on the form like a label
Loop

See Also:

driveCount | driveLetter | driveName | driveNum | driveReadType | driveSpeed | driveSpinUpTime

Apples To: AudioGrabber2


driveName property (AudioGrabber2)

driveName property (AudioGrabber2)

Read-only property that returns the name of the current CD drive in the system. The current CD drive must be set by the driveNum property preliminary.

Property type

A String value.

Syntax

[value = ]object.driveName

The driveName property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | String | The name of the current CD drive in the system.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Dim i As Integer
Dim DriveName As String
i = 0
Do While i < Grabber.driveCount
    i = i + 1
    Grabber.driveNum = i
    DriveName = ""
    If Grabber.driveLockCDTrayDuringGrab Then DriveName = "Locked"
    DriveName = DriveName & "Drive " & Grabber.driveNum & ": " & Grabber.driveName & " "
    DriveName = DriveName & Grabber.driveReadType & " with" & Grabber.driveSpead & "speed and Spin Up time:"
    DriveName = DriveName & Grabber.driveSpinUpTime & "ms"
    'For example this string with drive information can be visualized on the form like a label
Loop

See Also:

driveCount | driveLetter | driveLockCDTrayDuringGrab | driveNum | driveReadType | driveSpeed | driveSpinUpTime

Apples To: AudioGrabber2


driveNum property (AudioGrabber2)

driveNum property (AudioGrabber2)

Gets or sets the number of the current CD drive in the system.

Property type

A Long value.

Syntax

object.driveNum [= value]

The driveNum property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | This value can accept the value from 1 to the driveCount.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Dim i As Integer
Dim DriveName As String
i = 0
Do While i < Grabber.driveCount
    i = i + 1
    Grabber.driveNum = i
    DriveName = ""
    If Grabber.driveLockCDTrayDuringGrab Then DriveName = "Locked"
    DriveName = DriveName & "Drive " & Grabber.driveNum & ": " & Grabber.driveName & " "
    DriveName = DriveName & Grabber.driveReadType & " with" & Grabber.driveSpead & "speed and Spin Up time:"
    DriveName = DriveName & Grabber.driveSpinUpTime & "ms"
    'For example this string with drive information can be visualized on the form like a label
Loop

See Also:

driveCount | driveLetter | driveLockCDTrayDuringGrab | driveName | driveReadType | driveSpeed | driveSpinUpTime

Apples To: AudioGrabber2


driveReadType property (AudioGrabber2)

driveReadType property (AudioGrabber2)

Read-only property that returns the type of the CD.

Property type

A ReadTypeConstants value.

Syntax

[value = ]object.driveReadType

The driveReadType property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | ReadTypeConstants | The CD type.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Dim i As Integer
Dim DriveName As String
i = 0
Do While i < Grabber.driveCount
    i = i + 1
    Grabber.driveNum = i
    DriveName = ""
    If Grabber.driveLockCDTrayDuringGrab Then DriveName = "Locked"
    DriveName = DriveName & "Drive " & Grabber.driveNum & ": " & Grabber.driveName & " "
    DriveName = DriveName & Grabber.driveReadType & " with" & Grabber.driveSpead & "speed and Spin Up time:"
    DriveName = DriveName & Grabber.driveSpinUpTime & "ms"
    'For example this string with drive information can be visualized on the form like a label
Loop

See Also:

driveCount | driveLetter | driveLockCDTrayDuringGrab | driveName | driveNum | driveSpeed | driveSpinUpTime

Apples To: AudioGrabber2


driveSpeed property (AudioGrabber2)

driveSpeed property (AudioGrabber2)

Read-only property that returns the maximal drive speed during grabbing.

Syntax

[value = ]object.driveSpeed

The driveSpeed property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | Drive speed.

Remarks:

Real grabbing speed will be lower or equal to driveSpeed x 176 kB/sec. Max driveSpeed value can't be higher than 32.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Dim i As Integer
Dim DriveName As String
i = 0
Do While i < Grabber.driveCount
    i = i + 1
    Grabber.driveNum = i
    DriveName = ""
    If Grabber.driveLockCDTrayDuringGrab Then DriveName = "Locked"
    DriveName = DriveName & "Drive " & Grabber.driveNum & ": " & Grabber.driveName & " "
    DriveName = DriveName & Grabber.driveReadType & " with" & Grabber.driveSpead & "speed and Spin Up time:"
    DriveName = DriveName & Grabber.driveSpinUpTime & "ms"
    'For example this string with drive information can be visualized on the form like a label
Loop

See Also:

driveCount | driveLetter | driveLockCDTrayDuringGrab | driveName | driveNum | driveReadType | driveSpinUpTime

Apples To: AudioGrabber2


driveSpinUpTime property (AudioGrabber2)

driveSpinUpTime property (AudioGrabber2)

Gets or sets drive Spin Up time before grabbing.

Syntax

object.driveSpinUpTime [= value]

The driveSpinUpTime property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | Spin Up time is in milliseconds.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Dim i As Integer
Dim DriveName As String
i = 0
Do While i < Grabber.driveCount
    i = i + 1
    Grabber.driveNum = i
    DriveName = ""
    If Grabber.driveLockCDTrayDuringGrab Then DriveName = "Locked"
    DriveName = DriveName & "Drive " & Grabber.driveNum & ": " & Grabber.driveName & " "
    DriveName = DriveName & Grabber.driveReadType & " with" & Grabber.driveSpead & "speed and Spin Up time:"
    DriveName = DriveName & Grabber.driveSpinUpTime & "ms"
    'For example this string with drive information can be visualized on the form like a label
Loop

See Also:

driveCount | driveLetter | driveLockCDTrayDuringGrab | driveName | driveNum | driveReadType | driveSpeed

Apples To: AudioGrabber2


GrabModePreset property (AudioGrabber2)

grabModePreset property (AudioGrabber2)

Gets or sets grab mode preset.

Syntax

object.GrabModePreset [= value]

The GrabModePreset property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | GrabModePreset | Preset type.

Remarks:

Applies to GrabTrackToRaw, GrabTrackToWav, ReadTrack methods.

See Also:

grabOnErrorAction | grabOnErrorRetries | grabSafeMode | grabUseExternalASPI

Apples To: AudioGrabber2


grabOnErrorAction property (AudioGrabber2)

grabOnErrorAction property (AudioGrabber2)

Gets or sets an action on reading or synching an error during grabbing.

Property type

A GrabActionOnError value.

Syntax

object.grabOnErrorAction [= value]

The grabOnErrorAction property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | GrabActionOnError |

Remarks:

Applies to GrabToRaw, GrabToWav, ReadTrack methods.

See Also:

GrabModePreset | grabOnErrorRetries | grabSafeMode | grabUseExternalASPI

Apples To: AudioGrabber2


grabOnErrorRetries property (AudioGrabber2)

grabOnErrorRetries property (AudioGrabber2)

Gets or sets re-read retries number on reading or synching an error during grabbing.

Syntax

object.grabOnErrorRetries [= value]

The grabOnErrorRetries property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | Retries number.

Remarks:

Applies to GrabTrackToRaw, GrabTrackToWav, ReadTrack methods.

See Also:

GrabModePreset | grabOnErrorAction | grabSafeMode | grabUseExternalASPI

Apples To: AudioGrabber2


grabSafeMode property (AudioGrabber2)

grabSafeMode property (AudioGrabber2)

Gets or sets a flag indicating if safe grabbing mode is enabled or not.

Syntax

[value = ]object.grabSafeMode

The grabSafeMode property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Boolean | True if safe grabbing mode is enabled, otherwise - False.

Remarks:

Set Safe Mode parameters using SetSafeModeParams method.

It is recommended to use grabbing safe mode for a long grabbing operation.

After a certain grabbing time (default is 15 min) the drive will cool down for another period of time (default is 1 min)

See Also:

GrabModePreset | grabOnErrorAction | grabOnErrorRetries | grabUseExternalASPI

Apples To: AudioGrabber2


grabUseExternalASPI property (AudioGrabber2)

grabUseExternalASPI property (AudioGrabber2)

Gets or sets NCTAudioGrabber2 to use a third-party ASPI-driver.

Property type

A Boolean value.

Syntax

object.grabUseExternalASPI [= value]

The grabUseExternalASPI property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Boolean | True if external ASPI is used, otherwise - False.

Remarks:

By default NCTAudioGrabber2 uses NT Native SCSI Interface (SPTI) with Win NT/2000/XP and Native ASPI-layer with Win 98/ME. You can make NCTAudioGrabber2 work through a third-party ASPI-layer with this property. If this property is set to TRUE the wnaspi32.dll will be loaded and a third-party ASPI-layer become a SCSI manager.

See Also:

GrabModePreset | grabOnErrorAction | grabOnErrorRetries | grabSafeMode

Apples To: AudioGrabber2


LastErrorNum property (AudioGrabber2)

LastErrorNum property (AudioGrabber2)

Read-only property that returns the number of the last error.

Property type

An ErrorConstants value.

Syntax

[value = ]object.LastErrorNum

The LastErrorNum property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | ErrorConstants | Error code.

Remarks:

At present you can use two ways for an errors catch: using the standard error processor from VB or using the LastErrorNum property.

See Also:

Apples To: AudioGrabber2


sfmdCoolDownTime property (AudioGrabber2)

sfmdCoolDownTime property (AudioGrabber2)

Read-only property that returns safe mode cool down time.

Property type

A Long value.

Syntax

[value = ]object.sfmdCoolDownTime

The sfmdCoolDownTime property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | The safe mode cool down time.

Remarks:

Set Safe mode cool down time using SetSafeModeParams method.

See Also:

sfmdGrabTime

Apples To: AudioGrabber2


sfmdGrabTime property (AudioGrabber2)

sfmdGrabTime property (AudioGrabber2)

Read-only property that returns safe mode grabbing time.

Property type

A Long value.

Syntax

[value = ]object.sfmdGrabTime

The sfmdGrabTime property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | The safe mode grab time.

Remarks:

Set Safe mode grab time using SetSafeModeParams method.

See Also:

sfmdCoolDownTime

Apples To: AudioGrabber2


Status property (AudioGrabber2)

Status property (AudioGrabber2)

Read-only property that returns the current status of the control if extracting audio operations in progress.

Property type

A Long value.

Syntax

[value = ]object.Status

The Status property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | 0, if track isn't opened, 1 if track is opened for reading.

Remarks:

OpenTrack, CloseTrack, GrabTrackToWav, GrabTrackToRaw methods change the Status property. If Status = False ReadTrack and SeekTrack methods make no effect.

See Also:

Apples To: AudioGrabber2


trackCount property (AudioGrabber2)

trackCount property (AudioGrabber2)

Read-only property that returns the number of tracks on the compact disk.

Property type

A Long value.

Syntax

[value = ]object.trackCount

The trackCount property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | Number of tracks.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.trackNum = Grabber.trackCount
Grabber.GrabTrackToWav "C:\track_" & Grabber.trackNum & ".wav"
...
Grabber.CancelGrab

See Also:

trackDuration | trackNum | trackSamples

Apples To: AudioGrabber2


trackDuration property (AudioGrabber2)

trackDuration property (AudioGrabber2)

Read-only property that returns the duration of the track, which is set using the cdNum property.

Property type

A Long value.

Syntax

[value = ]object.trackDuration

The trackDuration property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | The duration is in milliseconds.

Remarks:

You can get the number of the current track by using the trackNum property.

See Also:

trackCount | trackNum | trackSamples

Apples To: AudioGrabber2


trackNum property (AudioGrabber2)

trackNum property (AudioGrabber2)

Gets or sets the current track.

Property type

A Long value.

Syntax

object.trackNum [= value]

The trackNum property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | The current track. This value can accept the value from 1 to the trackCount property.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.trackNum = Grabber.trackCount
Grabber.GrabTrackToWav "C:\track_" & Grabber.trackNum & ".wav"
...
Grabber.CancelGrab

See Also:

trackCount | trackDuration | trackSamples

Apples To: AudioGrabber2


trackSamples property (AudioGrabber2)

trackSamples property (AudioGrabber2)

Read-only property that returns the number of samples in the track, which is set using the trackNum property.

Property type

A Long value.

Syntax

[value = ]object.trackSamples

The trackSamples property syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
value | Long | The number of samples in the track

See Also:

trackCount | trackDuration | trackNum

Apples To: AudioGrabber2


AudioGrabber2 methods

AudioGrabber2 methods

Method | Description
CancelGrab | Cancels grabbing operation, which begins by the GrabTrakToWav or GrabTrakToRaw methods.
CloseTrack | Closes an audio track, opened before by the OpenTrack method.
DriverClose | Closes the driver opened by DriverOpen method.
DriverOpen | Opens the driver for reading.
Eject | Opens the CD drive's tray.
GetCDDBInfo | Gets information about an audio disk from the pointed CDDB Source.
GrabTrackToRaw | Grabs the current track to a RAW file. The current track must be set by the trackNum property.
GrabTrackToWav | Grabs the current track to a WAV file. The current track must be set by the trackNum property.
OpenTrack | Opens an audio track for reading before applying the ReadTrack method.
ReadTrack | Reads an audio data array from the current position of the track, opened before by the OpenTrack method.
RefreshCD | Re-read the drive.
Register | Enters user name and registration password to disable About window.
SeekTrack | Sets the current position on the track, opened by the OpenTrack method.
SetSafeModeParams | Sets safe mode Parameters.


CancelGrab method

CancelGrab method

Cancels grabbing operation, which begins by the GrabTrakToWav or GrabTrakToRaw methods.

Syntax

object.CancelGrab()

The CancelGrab method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.trackNum = Grabber.trackCount
Grabber.GrabTrackToWav "C:\track_" & Grabber.trackNum & ".wav"
...
Grabber.CancelGrab

See Also:

CloseTrack | Eject | GetCDDBInfo | GrabTrackToRaw | GrabTrackToWav | OpenTrack | ReadTrack | RefreshCD | Register | SeekTrack | SetSafeModeParams

Apples To: AudioGrabber2


CloseTrack method

CloseTrack method

Closes an audio track, opened before by the OpenTrack method.

Syntax

object.CloseTrack()

The CloseTrack method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.

See Also:

CancelGrab | Eject | GetCDDBInfo | GrabTrackToRaw | GrabTrackToWav | OpenTrack | ReadTrack | RefreshCD | Register | SeekTrack | SetSafeModeParams

Apples To: AudioGrabber2


DriverClose method

NCTAudioGrabber ActiveX DLL
DriverClose method (AudioGrabber2 object)

Closes the driver opened by DriverOpen method.

Syntax

object.DriverClose()

The DriverClose method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.

See Also:

DriverOpen

Applies to: AudioGrabber2

Send Feedback on the NCTAudioGrabber documentation.
NCTAudioGrabber was developed by NCT company http://www.nctsoft.com


DriverOpen method

NCTAudioGrabber ActiveX DLL
DriverOpen method (AudioGrabber2 object)

Opens the driver for reading.

Syntax

object.DriverOpen()

The DriverOpen method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.

Remarks:

Use this method before applying other methods and properties. Only Register method can be applied before this method.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.DriverOpen
Grabber.driveNum = Grabber.driveCount
...
Grabber.DriverClose

See Also:

DriverClose

Applies to: AudioGrabber2

Send Feedback on the NCTAudioGrabber documentation.
NCTAudioGrabber was developed by NCT company http://www.nctsoft.com


Eject method

Eject method

Opens the CD drive's tray.

Syntax

object.Eject

The Eject method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.

See Also:

CancelGrab | CloseTrack | GetCDDBInfo | GrabTrackToRaw | GrabTrackToWav | OpenTrack | ReadTrack | RefreshCD | Register | SeekTrack | SetSafeModeParams

Apples To: AudioGrabber2


GetCDDBInfo method

GetCDDBInfo method

Gets information about an audio disk from the pointed CDDB Source.

Return Type

A Boolean value.

Syntax

GetCDDBInfo = object.GetCDDBInfo(CDDBSource As CDDBSource)

The GetCDDBInfo method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
CDDBSource | CDDBSource | By default CDDBSource is equal to ALL.
GetCDDBInfo | Boolean | Indicates, if CDDB Info was retrieved or not.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.GetCDDBInfo  , TRUE
Grabber.cddbAgentName = "NCTAudioGrabber2 2.2"
Grabber.cddbCGIScript = "/~cddb/cddb.cgi"
Album.Caption = Grabber.cddbInfoAlbum
Artist.Caption = Grabber.cddbInfoArtist
Genre.Caption = Grabber.cddbInfoGenre
Title.Caption = Grabber.cddbInfoTitle
Grabber.cddbServerAddress = "http://freedb.freedb.org"
Grabber.cddbServerHTTPPort = 80
Timeout.Caption = Grabber.cddbTimeOut & "ms"
Grabber.cddbUserEMail = "support@nctsoft.com"

See Also:

CancelGrab | CloseTrack | Eject | GrabTrackToRaw | GrabTrackToWav | OpenTrack | ReadTrack | RefreshCD | Register | SeekTrack | SetSafeModeParams

Apples To: AudioGrabber2


GrabTrackToRaw method

GrabTrackToRaw method

Grabs the current track to a RAW file. The current track must be set by the trackNum property.

Syntax

object.GrabTrackToRaw(fileName As String)

The GrabTrackToRaw method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
fileName | String | Pathname of a RAW file.

See Also:

CancelGrab | CloseTrack | Eject | GetCDDBInfo | GrabTrackToWav | OpenTrack | ReadTrack | RefreshCD | Register | SeekTrack | SetSafeModeParams

Apples To: AudioGrabber2


GrabTrackToWav method

GrabTrackToWav method

Grabs the current track to a WAV file. The current track must be set by the trackNum property.

Syntax

object.GrabTrackToWav(fileName As String)

The GrabTrackToWav method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
fileName | String | Pathname of a WAV file.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Grabber.trackNum = Grabber.trackCount
Grabber.GrabTrackToWav "C:\track_" & Grabber.trackNum & ".wav"
...
Grabber.CancelGrab

See Also:

CancelGrab | CloseTrack | Eject | GetCDDBInfo | GrabTrackToRaw | OpenTrack | ReadTrack | RefreshCD | Register | SeekTrack | SetSafeModeParams

Apples To: AudioGrabber2


OpenTrack method

OpenTrack method

Opens an audio track for reading before applying the ReadTrack method.

Syntax

object.OpenTrack(trackNum As Long)

The OpenTrack method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
trackNum | Long | The number of track to open.

Remarks:

The track can be closed by the CloseTrack method.

See Also:

CancelGrab | CloseTrack | Eject | GetCDDBInfo | GrabTrackToRaw | GrabTrackToWav | ReadTrack | RefreshCD | Register | SeekTrack | SetSafeModeParams

Apples To: AudioGrabber2


ReadTrack method

ReadTrack method

Reads an audio data array from the current position of the track, opened before by the OpenTrack method.

Return Type

An Integer() value.

Syntax

ReadTrack = object.ReadTrack(nSamples As Long)

The ReadTrack method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
nSamples | Long | Number of read samples.
ReadTrack | Integer() | An audio data array.

See Also:

CancelGrab | CloseTrack | Eject | GetCDDBInfo | GrabTrackToRaw | GrabTrackToWav | OpenTrack | RefreshCD | Register | SeekTrack | SetSafeModeParams

Apples To: AudioGrabber2


RefreshCD method

RefreshCD method

Re-read the disk.

Syntax

object.RefreshCD()

The RefreshCD method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.

Example:

' VB sample where Grabber is an AudioGrabber2 objects.
Dim cdTypeString As String
AGrabber.RefreshCD
Select Case Grabber.cdType
Case UNRECOGNIZED:
cdTypeString = "No Disc"
Case REDBOOK:
cdTypeString = "CD Digital Audio Disk"
Case YELLOWBOOK:
cdTypeString = "Data CD. Single Session"
Case ORANGEBOOK:
cdTypeString = "Data CD (Multisession)"
Case GREENBOOK:
cdTypeString = "CD-Interactive"
Case BLUEBOOK:
cdTypeString = "CD-Extra"
End Select

See Also:

CancelGrab | CloseTrack | Eject | GetCDDBInfo | GrabTrackToRaw | GrabTrackToWav | OpenTrack | ReadTrack | Register | SeekTrack | SetSafeModeParams

Apples To: AudioGrabber2


Register method

Register method

Enters user name and registration password to disable About window.

Syntax

object.Register(bstrUser As String, bstrPassword As String)

The Register method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object of type .
bstrUser | String | User name. You get a registration user name after the registration.
bstrPassword | String | Password string. You get a registration password after the registration.

See Also:

CancelGrab | CloseTrack | Eject | GetCDDBInfo | GrabTrackToRaw | GrabTrackToWav | OpenTrack | ReadTrack | RefreshCD | SeekTrack | SetSafeModeParams

Apples To: AudioGrabber2


SeekTrack method

SeekTrack method

Sets the current position on the track, opened by the OpenTrack method.

Return Type

A Long value.

Syntax

CurrentSample = object.SeekTrack(nSamples As Long, Origin As FileSeekConstants)

The SeekTrack method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
nSamples | Long | Number of samples from the origin position.
Origin | FileSeekConstants | Type of the origin position. By default Origin is set to BEGIN_POS.
CurrentSample | Long | Current sample in the audio file.

See Also:

CancelGrab | CloseTrack | Eject | GetCDDBInfo | GrabTrackToRaw | GrabTrackToWav | OpenTrack | ReadTrack | RefreshCD | Register | SetSafeModeParams

Apples To: AudioGrabber2


SetSafeModeParams method

SetSafeModeParams method

Sets safe mode Parameters.

Syntax

object.SetSafeModeParams(timeGrab As Long, timeCoolDown As Long)

The SetSafeModeParams method syntax has these parts:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.
timeGrab | Long | Safe mode grabbing time.
timeCoolDown | Long | Safe mode cool down time.

See Also:

CancelGrab | CloseTrack | Eject | GetCDDBInfo | GrabTrackToRaw | GrabTrackToWav | OpenTrack | ReadTrack | RefreshCD | Register | SeekTrack

Apples To: AudioGrabber2


AudioGrabber2 events

AudioGrabber2 events

Event | Description
CDDBQueryStatus | During GetCDDBInfo method informs about CDDB Query Status.
EndReadTrack | Occurs when reading of the track is completed after applying of the ReadTrack method.
GrabBlock | Occurs when the procedure of block grabbing is completed in a grabbing process.
GrabRetry | Occurs when a retry of grabbing operation takes place.
MediaChange | Occurs when the user Ejects or Inserts a disk in the CD-Drive.


CDDBQueryStatus event

CDDBQueryStatus event

During GetCDDBInfo method informs about CDDB Query Status.

Syntax

Sub object_CDDBQueryStatus(CDDBQueryStatus As CDDBQueryStatus)

The CDDBQueryStatus event syntax has these named arguments:

Part | Type | Description
CDDBQueryStatus | CDDBQueryStatus | CDDB Query Status.

Example:

' VB sample where AudioGrabber21 is an AudioGrabber2 object.
Private Sub AudioGrabber21_CDDBQueryStatus(ByVal cddbQueryStatus As cddbQueryStatus)
    'this event informs AudioGrabber2 ActiveX client about current status of CDDB query
    Select Case cddbQueryStatus 'depends on CDDB query status
    Case QUERY
        'if status is Query
        StatusBar1.Panels(4).Text = "CDDB Status: QUERY"
        'Sets Status Bar Panel(4) to Query status
    Case PROCESSANSWER 'if status is ProcessAnswer
        StatusBar1.Panels(4).Text = "CDDB Status: PROCESS ANSWER"
        'Sets Status Bar Panel(4) to Process Answer status
    End Select
End Sub


EndReadTrack event

EndReadTrack event

Occurs when reading of the track is completed after applying of the ReadTrack method.

Syntax

Sub object_EndReadTrack(Result As Boolean)

The EndReadTrack event syntax has these named arguments:

Part | Type | Description
Result | Boolean | True if an audio track was read with errors, otherwise - False.

Example:

' VB sample where AudioGrabber21 is an AudioGrabber2 object.
Private Sub AudioGrabber21_EndReadTrack(ByVal Result As Boolean)
'this event occurs when ReadTrack Method ends
    If Result = True Then   'if the result equals true then
        MsgBox "An error occures when ReadTrack works! Probably need re-read!"
        'produces the message box with a message about the error occurring
    End If
    If CancelGrb = True Then AudioGrabber21.CancelGrab
'CancelGrb was set to true then stops grabbing procedure
End Sub

See Also:

Apples To: AudioGrabber2


GrabBlock event

GrabBlock event

Occurs when the procedure of block grabbing is completed in a grabbing process.

Syntax

Sub object_GrabBlock(Percent As Long)

The GrabBlock event syntax has these named arguments:

Part | Type | Description
Percent | Long | Execution percent.

Example:

' VB sample where AudioGrabber21 is an AudioGrabber2 object.
Private Sub AudioGrabber21_GrabBlock(ByVal Percent As Long)
    'this event sub occurs when block is completed in grabbing process
    txtDriveStatus.Caption = "Extracting Audio"
    're-sets drive status label to the current drive status
    If ProgressBar1.Value = Percent Then
        'if it is no progress in grab - it is a drive cool down
        txtDriveStatus.Caption = "Cool Down"
        'sets drive status label to the current drive status
    Else
        'if it is progress in grab
        ProgressBar1.Value = Percent
        'sets the value of the progress bar to the percent
    End If
    retryNum = 0    'sets re-read number to zero
    DoEvents
    'Yields execution so that operating system could produce the other events
    If CancelGrb = True Then AudioGrabber21.CancelGrab
    'if CancelGrb was set to true then stops grabbing procedure if
End Sub

See Also:

cdType

Apples To: AudioGrabber2


GrabRetry event

GrabRetry event (AudioGrabber2 object)

Occurs when a retry of grabbing operation takes place.

Syntax

Sub object_GrabRetry()

Example:

' VB sample where AudioGrabber21 is an AudioGrabber2 object.
Private Sub AudioGrabber21_GrabRetry()
    MsgBox "Grab retry"
End Sub

See Also:

Applies to: AudioGrabber2

Send Feedback on the NCTAudioGrabber2 documentation.
NCTAudioGrabber2 was developed by NCT company http://www.nctsoft.com


MediaChange event

MediaChange event

Occurs when the user Ejects or Inserts a disk in the CD-Drive.

Syntax

object.MediaChange()

The MediaChange event syntax has these named arguments:

Part | Type | Description
object | AudioGrabber2 | An expression evaluating to an object.

Remarks:

Recommended to use for automatical Refresh on Insert/Eject Disk. This event also may occur when CD-Drive wakes-up, Bus Reset (makes disk TOC re-read) or disk TOC change (other program writes data on this disk).

Example:

' VB sample where AudioGrabber21 is an AudioGrabber2 object.
Private Sub AudioGrabber21_MediaChange()
    'this event occurs when user eject or insert the disk
    Inactive    'Inactive form controls that can't be use during refresh
    RefreshCD   'Calls the RefreshCD sub
    Active      'Active the form controls
End Sub

See Also:

Apples To: AudioGrabber2


NCTAudioGrabber2 constants

NCTAudioGrabber2 constants

Constants | Description
CDDBQueryStatus | These are the constants for the CDDBQueryStatus event.
CDDBSource | These are the constants for the GetCDDBInfo method.
CDDiskType | These are the constants for the cdType property (AudioGrabber2).
ErrorConstants | These are the constants for the LastErrorNum property (AudioGrabber2).
FileSeekConstants | These are the constants for the SeekTrack method.
GrabActionOnError | These are the constants for the grabOnErrorAction property (AudioGrabber2).
GrabModePreset | These are the constants for the GrabModePreset property (AudioGrabber2).
ReadTypeConstants | These are the constants for the driveReadType property (AudioGrabber2).


CDDBQueryStatus enumeration

CDDBQueryStatus enumeration

These are the constants for the CDDBQueryStatus event.

Members

Constant | Value | Description
QUERY | 0 | Query the CD Data Base Server or Search in CDPLAYER.INI, depending on CDDBSourse.
PROCESSANSWER | 1 | Process the answer, returned by CDDB or data from CDPLAYER.INI, depending on CDDBSourse.


CDDBSource enumeration

CDDBSource enumeration

These are the constants for the GetCDDBInfo method.

Members

Constant | Value | Description
ALL | 0 | Default. Both CDDB Sources.
ONLINEDATABASE | 1 | CDDB On-Line Data Base.
CDPLAYERINI | 2 | File "cdplayer.ini" on local computer.


CDDiskType enumeration

CDDiskType enumeration

These are the constants for the cdType property (AudioGrabber2).

Members

Constant | Value | Description
UNRECOGNIZED | 0 | No Disk, Disk Unreadable or CD-Drive Malfunction.
REDBOOK | 1 | CD Digital Audio Disk (Contains only audio tracks).
YELLOWBOOK | 2 | Data CD. Single Session. CD-ROM Disk, for example.
ORANGEBOOK | 3 | Data CD (Multisession).
GREENBOOK | 4 | CD-Interactive.
BLUEBOOK | 5 | CD-Extra. Disk contains audio tracks and data files. Usually multisession.


ErrorConstants enumeration

ErrorConstants enumeration

These are the constants for the LastErrorNum property (AudioGrabber2).

Members

Part | Value | Description
NOERRORS | 0 | No errors.
BUSY | -10 | It is impossible to execute the current method because the application is busy by another one.
MEMORY | -11 | Memory error.
FORMATFILE | -12 | Wrong file format. It is an attempt to open a non-audio file as an audio file.
FORMATNOTSUPPORT | -13 | Unsupported audio file format. It is an attempt to open an unsupported audio file format.
OUTDRIVER | -14 | Output audio device error. For example: wrong device, audio device is already opened in your application or is in use by another one and many others… It hardly depends on hardware.
INPDRIVER | -15 | Input audio device error. . For example: wrong device, audio device is already opened in your application or is in use by another one and many others… It hardly depends on hardware.
MIXERDRIVER | -16 | Mixer device driver error.
ACMDRIVER | -17 | ACM driver error.
FILEACCESS | -18 | The specified file is already in use.
INVALIDOPERATION | -19 | Invalid operation. For example, you try to execute READ method before OPEN method.
INVALIDPARAM | -20 | Invalid parameters. You try to execute a method with invalid parameters.
ASPIDRIVER | -21 | Incorrect CD driver operation. ASPI driver returns an error.
CONTROLNOTINSTALLED | -22 | Control not installed.
INDEXOUTOFRANGE | -23 | Incorrect address to the array. Index out of the array range.
STREAM | -24 |
UNEXPECTED | -40 | Unexpected error.


FileSeekConstants enumeration

FileSeekConstants enumeration

These are the constants for the SeekTrack method.

Members

Constant | Value
CURRENT_POS | 1
BEGIN_POS | 3
END_POS | 2


GrabActionOnError enumeration

GrabActionOnError enumeration

These are the constants for the grabOnErrorAction property (AudioGrabber2).

Members

Constant | Value | Description
STOPGRAB | 0 | Stop grab if read or synch error occurs.
SILENCE | 1 | Insert silence (null amplitude) block on error block place.
CUT | 2 | Cut error block.
CORRECT | 3 | Correct error block using build-in error correction algorithm.


GrabModePreset enumeration

GrabModePreset enumeration

These are the constants for the GrabModePreset property (AudioGrabber2).

Members

Constant

Value

Description

Play

0

Optimimal for digital CD play.

No jitter correction. Large block read at once. Retries on Read error is 7. Spin up drive before read track during 100ms. Max grab speed is 32. Safe Mode Off. grabActionOnError = SILENCE

BURST

1

Optimimal for fast grab.

No jitter correction. Normal block read at once. Retries on Read error is 50. Drive spin up the disk during 1000ms before read track. Max grab speed is 32.

SYNCH

2

Optimimal for precision grab.

Jitter errors correction. Normal block read at once. Retries on Read or Synch error is 100. Drive spin up the disk during 3000ms before read track. Max grab speed is 24.

SECURE

3

Optimimal for precision grab of old and very used CD.

Jitter errors correction. Normal block read at once. Retries on Read or Synch error is 100. Drive spin up the disk during 3000ms before read track. Max grab speed is 16..

Every block reads and re-reads before the number of the blocks, contains the same data will be 50% or more from the number of read blocks.

PARANOID

4

Optimal only for grab on unreadable (scratched) CD.

Jitter errors correction. Very small block read at once. Retries on Read or Synch error is 125. Drive don't spin up the disk before read track. Max grab speed is 1.

If CD drive caches audio data, catch will be disable. Every block reads and re-reads before the number of the blocks, contains the same data will be 50% or more from the number of read blocks.

This mode recommended to use with grabOnErrorAction = SILENCE, CUT or CORRECT. Also it is recommended to enable grabSafeMode.


ReadTypeConstants enumeration

ReadTypeConstants enumeration

These are the constants for the driveReadType property (AudioGrabber2).

Members

Constant | Value | Description
CDRT_ANY | 0 | Autodetect.
CDRT_ATAPI1 | 1 | ATAPI [1]
CDRT_ATAPI2 | 2 | ATAPI [2]
CDRT_READ6 | 3 | SCSI - Generic
CDRT_READ10 | 4 | SCSI - Plexdor
CDRT_READ_D8 | 5 | SCSI - Nec
CDRT_READ_D4 | 6 | SCSI - Generic [2]
CDRT_READ_D4_1 | 7 | SCSI - NEC [2]
CDRT_READ10_2 | 8 |


AudioGrabber2

NCTAudioStudio2 ActiveX DLLs

Version 2.2

NCTAudioGrabber2 ActiveX DLL is intended for grabbing audio from an audio CD.

With NCTAudioGrabber2 ActiveX DLL you can:

  • Determinate the type of a drive;

  • Determinate the number of tracks on an audio disk;

  • Grab audio tracks from an audio disk;

  • Get the CDDB info.

NCTAudioGrabber2 is a part of the NCTAudioStudio2 package.


Error event

Error event

Occurs when any error takes place.

Syntax

Sub object_Error(Code As ErrorConstants)

The Error event syntax has these named arguments:

Part | Type | Description
Code | ErrorConstants | Error code.

Example:

' VB sample where AudioGrabber21 is an AudioGrabber2 object.
Private Sub AudioGrabber21_Error(ByVal Code As ErrorConstants)
    'this event occurs when reading of track is completed after applying ReadTrack method
    MsgBox "An error occurs! Error Code " & Code
    'produces the message box with a message about the error occurring
End Sub

See Also:

Apples To: AudioGrabber2


Genre

Audio file genres

Value

Blues

Classic Rock

Country

Dance

Disco

Funk

Grunge

Hip-Hop

Jazz

Metal

New Age

Oldies

Other

Pop

R&B

Rap

Reggae

Rock

Techno

Industrial

Alternative

Ska

Death Metal

Pranks

Soundtrack

Euro-Techno

Ambient

Trip-Hop

Vocal

Jazz+Funk

Fusion

Trance

Classical

Instrumental

Acid

House

Game

Sound Clip

Gospel

Noise

Alternative Rock

Bass

Soul

Punk

Space

Meditative

Instrumental Pop

Instrumental Rock

Ethnic

Gothic

Darkwave

Techno-Industrial

Electronic

Pop-Folk

Eurodance

Dream

Southern Rock

Comedy

Cult

Gangsta

Top 40

Christian Rap

Pop/Funk

Jungle

Native US

Cabaret

New Wave

Psychedelic

Rave

Showtunes

Trailer

Lo-Fi

Tribal

Acid Punk

Acid Jazz

Polka

Retro

Musical

Rock & Roll

Hard Rock

Folk

Folk-Rock

National Folk

Swing

Fast Fusion

Bebob

Latin

Revival

Celtic

Bluegrass

Avantgarde

Gothic Rock

Progressive Rock

Psychedelic Rock

Symphonic Rock

Slow Rock

Big Band

Chorus

Easy Listening

Acoustic

Humour

Speech

Chanson

Opera

Chamber Music

Sonata

Symphony

Booty Bass

Primus

Porn Groove

Satire

Slow Jam

Club

Tango

Samba

Folklore

Ballad

Power Ballad

Rhythmic Soul

Freestyle

Duet

Punk Rock

Drum Solo

Acapella

Euro-House

Dance Hall

Goa

Drum & Bass

Club-House

Hardcore

Terror

Indie

BritPop

Negerpunk

Polsk Punk

Beat

Christian Gangsta

Heavy Metal

Black Metal

Crossover

Contemporary C

Christian Rock

Merengue

Salsa

Thrash Metal

Anime

JPop

SynthPop


NCTAudioGrabber2Lib

NCTAudioStudio2 ActiveX DLLs

Version 2.2

NCTAudioGrabber2 ActiveX DLL is intended for grabbing audio from an audio CD.

With NCTAudioGrabber2 ActiveX DLL you can:

  • Determinate the type of a CD drive;

  • Determinate the number of tracks on an audio CD;

  • Grab audio tracks from an audio CD;

  • Get the CDDB info.

NCTAudioGrabber2 is a part of the NCTAudioStudio2 package.